WordPress plugins update protection

Het mooie van WordPress is dat je bijna voor elke aanpassing in het CMS wel een plugin hebt. De volgende plugin maakt het mogelijk om plugins voor een update te blokkeren. Waarom zou je dit willen doen? Wordpress-protect-plugins

WordPress, Open Source CMS

WordPress is een open source CMS. Nu is het zo, dat je ten alle tijde met je vingers van de core broncode(WordPress zelf) moet afblijven, omdat dit tot hele vervele resultaten kan leiden bij het updaten van WordPress. Ook moet je er voor oppassen om zelf middels handigheidjes WordPress om de tuin leidt. Dit, door bijvoorbeeld zelf op creatieve wijze direct de SQL database te benaderen, zonder de WordPress query mogelijkheden te gebruiken.

Wijzigingen in het thema

De meeste wijzigingen zal menigeen aanbrengen in het thema. Daar is op zich niks mis mee, maar ga er niet vanuit dat de ontwikkelaar van het thema hier ook rekening mee zal houden. Dus bij een eventuele update kan dit tot vervelende resultaten leiden. Het kan in dat geval zelfs gebeuren dat ook CSS classes niet meer bestaan in de update, met alle gevolgen voor je wijzigingen vandien. Het is jammer dat WordPress niet voorziet in regels voor thema’s met betrekking tot exit-points en forks.

Genesis

Het Genesis framework bestaat uit een basis framework, waarop child themes worden gebouwd. Dit zorgt er op z’n minst voor dat deze kinderen in de meeste gevallen de regels van het basis framework respecteren.

Block Specific Plugin Update

Het komt regelmatig voor dat je een plugin wil aanpassen, omdat de ontwikkelaar iets over het hoofd heeft gezien, of gewoon omdat je de plugin wil uitbreiden met je eigen opties. Op dat moment is het onwenselijk dat je de plugin nog wil automatisch wil updaten indien er een nieuwe versie komt. Middels de plugin Block Specific Plugin Update is het mogelijk selectief plugins uit te schakelen voor een automatische update. Dit voorkomt dat je bij een update per ongeluk toch het vinkje verkeerd zet en je wijzigingen om zeep helpt. Het is daarna wel aan jou om er voor te zorgen dat je eigen custom versie van deze plugin waterdicht en veilig blijft.

Installatie en werkwijze

Het installeren is eenvoudig. Je gaat naar plugins in het WordPress menu. Vervolgens selecteer je nieuwe plugin. Je zoekt nu Block Specific Plugin Update en installeert deze plugin. Na het activeren van de plugin is er in het WordPress menu onder de optie Instellingen een optie Block Plugin Update bijgekomen. Na het klikken verschijnt er een dialoog met alle geïnstalleerde plugins.

image

Klik vervolgens de gewenste plugins aan en sla de wijzigingen op. Klaar is kees! Er wordt wel geadviseerd even opnieuw aan te loggen. De update melding voor de geselecteerde plugins worden niet meer aangegeven door WordPress.

Link: http://wordpress.org/extend/plugins/block-specific-plugin-updates/

Johan van de Merwe

Johan van de Merwe is sinds 1985 werkzaam in de automatisering. In 2007 heeft hij Enovision GmbH opgestart, welke is gespecialiseerd in internet toepassingen, presentatie en coaching. Voor Websprinter is hij werkzaam als internet coach voor het MKB.

You may also like...

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Verplichte velden zijn gemarkeerd met *